summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDominik Riebeling <Dominik.Riebeling@gmail.com>2008-08-31 12:32:27 +0000
committerDominik Riebeling <Dominik.Riebeling@gmail.com>2008-08-31 12:32:27 +0000
commitca588afe51bf3adb4abcb8dd723476ee075f6bd4 (patch)
tree66d572d59101fd24dc6e6d5be772a375edaad701
parentb7219b7e16bc12e43aaf33555fed7157dddf706f (diff)
downloadrockbox-ca588afe51bf3adb4abcb8dd723476ee075f6bd4.tar.gz
rockbox-ca588afe51bf3adb4abcb8dd723476ee075f6bd4.tar.bz2
rockbox-ca588afe51bf3adb4abcb8dd723476ee075f6bd4.zip
Let qmake check the Qt version and error out if its too old. Useful if you have Qt3 and Qt4 installed and forget to pick the correct one.
git-svn-id: svn://svn.rockbox.org/rockbox/trunk@18369 a1c6a512-1295-4272-9138-f99709370657
-rw-r--r--rbutil/rbutilqt/rbutilqt.pro8
1 files changed, 8 insertions, 0 deletions
diff --git a/rbutil/rbutilqt/rbutilqt.pro b/rbutil/rbutilqt/rbutilqt.pro
index f0c95ac5a0..6317da0dff 100644
--- a/rbutil/rbutilqt/rbutilqt.pro
+++ b/rbutil/rbutilqt/rbutilqt.pro
@@ -12,6 +12,14 @@ UI_DIR = build/ui
MOC_DIR = build/moc
RCC_DIR = build/rcc
+# check version of Qt installation
+VER = $$find(QT_VERSION, ^4\.[3-9]+.*)
+isEmpty(VER) {
+ !isEmpty(QT_VERSION) error("Qt found:" $$[QT_VERSION])
+ error("Qt >= 4.3 required!")
+}
+message("Qt version used:" $$VER)
+
# add a custom rule for pre-building librbspeex
!mac {
rbspeex.commands = @$(MAKE) -C ../../tools/rbspeex librbspeex.a