summaryrefslogtreecommitdiffstats
path: root/utils/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'utils/CMakeLists.txt')
-rw-r--r--utils/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/utils/CMakeLists.txt b/utils/CMakeLists.txt
index 500f9dab10..9797d020d3 100644
--- a/utils/CMakeLists.txt
+++ b/utils/CMakeLists.txt
@@ -104,6 +104,13 @@ endif()
target_compile_definitions(ipodpatcher PUBLIC RBUTIL _LARGEFILE64_SOURCE)
target_include_directories(ipodpatcher PUBLIC ${CMAKE_CURRENT_LIST_DIR}/ipodpatcher)
+add_executable(sansapatcher-bin
+ sansapatcher/main.c
+ )
+target_link_libraries(sansapatcher-bin sansapatcher)
+target_compile_definitions(sansapatcher-bin PRIVATE VERSION="none")
+set_target_properties(sansapatcher-bin PROPERTIES OUTPUT_NAME sansapatcher)
+
add_library(sansapatcher
sansapatcher/parttypes.h
sansapatcher/sansaio.h