summaryrefslogtreecommitdiffstats
path: root/firmware/export/config/cowond2.h
AgeCommit message (Collapse)AuthorFilesLines
2024-03-31rolo: simplify parsing scramble header in load_firmware()Aidan MacDonald1-6/+0
The standard load_firmware() function is used on targets which use the "scramble -add" method for generating Rockbox binaries. While it tries to be a bit more generic and allows the CRC/data offsets to be placed anywhere in the file, there are no targets which actually need this flexibility, because they are all using plain old "scramble -add". So we can actually simplify load_firmware() and remove defines from the target headers. All the targets used CRC offset = 0 and data offset = 8, except for a few which I assume never supported ROLO or were never tested -- eg. samsungyh820: the CRC and data offsets cannot both be 0. The actual motivation for this is removing the calls to lseek(), which can help make bootloaders a tiny bit smaller, as lseek is typically not used anywhere else in bootloaders. Change-Id: Ic2d01e5b75a32e88363f085e3e839146a0710bf4
2021-08-15Drop HAVE_RTC_RAMAidan MacDonald1-3/+0
Only Archos players ever used this feature and it isn't implemented on any current targets. Change-Id: I39c8455480a3fe33cd25b667e8d4d6ff3a092d3e
2020-07-24[4/4] Remove HAVE_LCD_BITMAP, as it's now the only choice.Solomon Peachy1-2/+2
Note: I left behind lcd_bitmap in features.txt, because removing it would require considerable work in the manual and the translations. Change-Id: Ia8ca7761f610d9332a0d22a7d189775fb15ec88a
2020-07-24[3/4] Completely remove HWCODEC supportSolomon Peachy1-2/+2
'swcodec' is now always set (and recording_swcodec for recording-capable units) in feature.txt so the manual and language strings don't need to all be fixed up. Change-Id: Ib2c9d5d157af8d33653e2d4b4a12881b9aa6ddb0
2020-05-24cowond2: Disable internal NAND storage; use only the SD card.Solomon Peachy1-2/+4
This allows the player to be usable. Slightly adapted from: https://forums.rockbox.org/index.php/topic,10164.msg245357.html#msg245357 Change-Id: I7bdd681b132cac4c82e3ba6aabe74169645eee4c
2015-01-08Get rid of USE_ROCKBOX_USBAmaury Pouly1-1/+0
Except for unfinished or experimental ports, it isthe case that USE_ROCKBOX_USB and HAVE_USBSTACK are both defined or both undefined. Furthermore, it is a leftover of some early developments on the USB stack and doesn't make sense anymore. Change-Id: Ic87a865b6bb4c7c9a8d45d1f0bb0f2fb536b8cad Reviewed-on: http://gerrit.rockbox.org/1091 Reviewed-by: Amaury Pouly <amaury.pouly@gmail.com>
2014-03-03Implement lcd_get_dpi() for all bitmap targets.Thomas Martitz1-0/+2
DPI values are autogenerated from the resolution and collected display size values. These values are inserted as comments as well. Change-Id: Id03aedf9af18348f773dfce002805e480f6751e8
2012-06-20Use RGB565 define instead of plain 565.Frank Gevaerts1-1/+1
Pixelformats should always use the defines, not the raw values. Change-Id: Id60a73385bb6cc4e8f8d1f8b292489d066f1e13f
2012-05-09Rename HAVE_PITCHSCREEN to HAVE_PITCHCONTROLNils Wallménius1-2/+0
Also move the definition to config.h Change-Id: I36bb5020c5e06b2344292bc05e8c13ccc7a6a1ff Reviewed-on: http://gerrit.rockbox.org/234 Reviewed-by: Nils Wallménius <nils@rockbox.org>
2012-01-07TARGET_TREE is not needed anymoreRafaël Carré1-1/+0
spotted by jhMikeS git-svn-id: svn://svn.rockbox.org/rockbox/trunk@31597 a1c6a512-1295-4272-9138-f99709370657
2012-01-03Rework powermgmt to enable code re-use on appliation and sims.Thomas Martitz1-0/+2
* Introduce CONFIG_BATTERY_MEASURE define, to allow targets (application) to break powermgmt.c's assumption about the ability to read battery voltage. There's now additionally percentage (android) and remaining time measure (maemo). No measure at all also works (sdl app). If voltage can't be measured, then battery_level() is king and it'll be used for power_history and runtime estimation. * Implement target's API in the simulator, i.e. _battery_voltage(), so it doesn't need to implement it's own powermgmt.c and other stubs. Now the sim behaves much more like a native target, although it still changes the simulated battery voltage quickly, * Other changes include include renaming battery_adc_voltage() to _battery_voltage(), for consistency with the new target functions and making some of the apps code aware that voltage and runtime estimation is not always available. git-svn-id: svn://svn.rockbox.org/rockbox/trunk@31548 a1c6a512-1295-4272-9138-f99709370657
2010-11-10Touchscreen: Improved scroll thresholdThomas Martitz1-0/+1
Remove the hardcoded (and way too small) scroll threshold (the distance moved in pixels before we think the users wants to scroll) and replace it with something based on the actual DPI of the screen. On Android we call the API for that, on other touchscreens we reimplemented Android's formula (as of 2.2) and calculate it. Flyspray: 11727 git-svn-id: svn://svn.rockbox.org/rockbox/trunk@28548 a1c6a512-1295-4272-9138-f99709370657
2010-07-18AB_REPEAT_ENABLE was never defined to 2Rafaël Carré1-1/+1
There's only 2 possibilities: defined or undefined git-svn-id: svn://svn.rockbox.org/rockbox/trunk@27483 a1c6a512-1295-4272-9138-f99709370657
2010-06-10Enable the hotkey feature on the touchscreen targets who now have a hotkey ↵Jonathan Gordon1-1/+1
touchregion settable in the wps (todo: touchregions in the sbs!) git-svn-id: svn://svn.rockbox.org/rockbox/trunk@26742 a1c6a512-1295-4272-9138-f99709370657
2010-04-01FS#11081 - Hotkey patch. Many targets supported, but some keymaps need work ↵Jeffrey Goode1-0/+2
before they can be switched on git-svn-id: svn://svn.rockbox.org/rockbox/trunk@25414 a1c6a512-1295-4272-9138-f99709370657
2009-12-15Cowon D2: Rename COWOND2_PAD -> COWON_D2_PAD to match macro used in manual, andTomer Shalev1-1/+1
to target naming conventions in general git-svn-id: svn://svn.rockbox.org/rockbox/trunk@24010 a1c6a512-1295-4272-9138-f99709370657
2009-12-07Rename targets to be consistent in all places. (FS #10819). Take 2.Björn Stenberg1-0/+171
git-svn-id: svn://svn.rockbox.org/rockbox/trunk@23883 a1c6a512-1295-4272-9138-f99709370657