summaryrefslogtreecommitdiffstats
path: root/firmware/target/arm/rk27xx/sd-rk27xx.c
AgeCommit message (Collapse)AuthorFilesLines
2021-03-27rk27xx: Take advantage of STORAGE_NEEDS_BOUNCE_BUFFERSolomon Peachy1-0/+9
(And get rid of its custom realignment code) Change-Id: Iff27d717b870d3db239310421776744ea6863373
2019-01-02Add Xuelin iHIFI 770/770C/800 supportSolomon Peachy1-8/+10
Taken from the xvortex fork (Roman Stolyarov) Ported, rebased, and cleaned up by myself. Change-Id: I7b2bca2d29502f2e4544e42f3d122786dd4b7978
2017-10-26Unify storage threads into oneMichael Sevakis1-118/+69
* Editing a bunch of drivers' thread routines in order to implement a new feature is tedious. * No matter the number of storage drivers, they share one thread. No extra threads needed for CONFIG_STORAGE_MULTI. * Each has an event callback called by the storage thread. * A default callback is provided to fake sleeping in order to trigger idle callbacks. It could also do other default processing. Changes to it will be part of driver code without editing each one. * Drivers may sleep and wake as they please as long as they give a low pulse on their storage bit to ask to go into sleep mode. Idle callback is called on its behalf and driver immediately put into sleep mode. * Drivers may indicate they are to continue receiving events in USB mode, otherwise they receve nothing until disconnect (they do receive SYS_USB_DISCONNECTED no matter what). * Rework a few things to keep the callback implementation sane and maintainable. ata.c was dreadful with all those bools; make it a state machine and easier to follow. Remove last_user_activity; it has no purpose that isn't served by keeping the disk active through last_disk_activity instead. * Even-out stack sizes partly because of a lack of a decent place to define them by driver or SoC or whatever; it doesn't seem too critical to do that anyway. Many are simply too large while at least one isn't really adequate. They may be individually overridden if necessary (figure out where). The thread uses the greatest size demanded. Newer file code is much more frugal with stack space. I barely see use crack 50% after idle callbacks (usually mid-40s). Card insert/eject doesn't demand much. * No forcing of idle callbacks. If it isn't necessary for one or more non-disk storage types, it really isn't any more necessary for disk storage. Besides, it makes the whole thing easier to implement. Change-Id: Id30c284d82a8af66e47f2cfe104c52cbd8aa7215
2014-11-29rk27xx: sd: properly align buffer used for DMA transfers.Andrew Ryabinin1-4/+23
Commit 7d1a47cf ("Rewrite filesystem code (WIP)") exposed bug in rk27xx sd driver. Buffer passed to sd_read/write_sectors() doesn't has to be cacheline aligned. DMA transfers on unaligned buffers is quiet dangerous thing. Make sure that the buffer is aligned to cacheline size, If not use a temporary aligned buffer for DMA transfer. Change-Id: I91420f2b8d58159c80c3f15f4b35e88ea0dfd14c
2014-08-30Rewrite filesystem code (WIP)Michael Sevakis1-29/+23
This patch redoes the filesystem code from the FAT driver up to the clipboard code in onplay.c. Not every aspect of this is finished therefore it is still "WIP". I don't wish to do too much at once (haha!). What is left to do is get dircache back in the sim and find an implementation for the dircache indicies in the tagcache and playlist code or do something else that has the same benefit. Leaving these out for now does not make anything unusable. All the basics are done. Phone app code should probably get vetted (and app path handling just plain rewritten as environment expansions); the SDL app and Android run well. Main things addressed: 1) Thread safety: There is none right now in the trunk code. Most of what currently works is luck when multiple threads are involved or multiple descriptors to the same file are open. 2) POSIX compliance: Many of the functions behave nothing like their counterparts on a host system. This leads to inconsistent code or very different behavior from native to hosted. One huge offender was rename(). Going point by point would fill a book. 3) Actual running RAM usage: Many targets will use less RAM and less stack space (some more RAM because I upped the number of cache buffers for large memory). There's very little memory lying fallow in rarely-used areas (see 'Key core changes' below). Also, all targets may open the same number of directory streams whereas before those with less than 8MB RAM were limited to 8, not 12 implying those targets will save slightly less. 4) Performance: The test_disk plugin shows markedly improved performance, particularly in the area of (uncached) directory scanning, due partly to more optimal directory reading and to a better sector cache algorithm. Uncached times tend to be better while there is a bit of a slowdown in dircache due to it being a bit heavier of an implementation. It's not noticeable by a human as far as I can say. Key core changes: 1) Files and directories share core code and data structures. 2) The filesystem code knows which descriptors refer to same file. This ensures that changes from one stream are appropriately reflected in every open descriptor for that file (fileobj_mgr.c). 3) File and directory cache buffers are borrowed from the main sector cache. This means that when they are not in use by a file, they are not wasted, but used for the cache. Most of the time, only a few of them are needed. It also means that adding more file and directory handles is less expensive. All one must do in ensure a large enough cache to borrow from. 4) Relative path components are supported and the namespace is unified. It does not support full relative paths to an implied current directory; what is does support is use of "." and "..". Adding the former would not be very difficult. The namespace is unified in the sense that volumes may be specified several times along with relative parts, e.g.: "/<0>/foo/../../<1>/bar" :<=> "/<1>/bar". 5) Stack usage is down due to sharing of data, static allocation and less duplication of strings on the stack. This requires more serialization than I would like but since the number of threads is limited to a low number, the tradoff in favor of the stack seems reasonable. 6) Separates and heirarchicalizes (sic) the SIM and APP filesystem code. SIM path and volume handling is just like the target. Some aspects of the APP file code get more straightforward (e.g. no path hashing is needed). Dircache: Deserves its own section. Dircache is new but pays homage to the old. The old one was not compatible and so it, since it got redone, does all the stuff it always should have done such as: 1) It may be update and used at any time during the build process. No longer has one to wait for it to finish building to do basic file management (create, remove, rename, etc.). 2) It does not need to be either fully scanned or completely disabled; it can be incomplete (i.e. overfilled, missing paths), still be of benefit and be correct. 3) Handles mounting and dismounting of individual volumes which means a full rebuild is not needed just because you pop a new SD card in the slot. Now, because it reuses its freed entry data, may rebuild only that volume. 4) Much more fundamental to the file code. When it is built, it is the keeper of the master file list whether enabled or not ("disabled" is just a state of the cache). Its must always to ready to be started and bind all streams opened prior to being enabled. 5) Maintains any short filenames in OEM format which means that it does not need to be rebuilt when changing the default codepage. Miscellaneous Compatibility: 1) Update any other code that would otherwise not work such as the hotswap mounting code in various card drivers. 2) File management: Clipboard needed updating because of the behavioral changes. Still needs a little more work on some finer points. 3) Remove now-obsolete functionality such as the mutex's "no preempt" flag (which was only for the prior FAT driver). 4) struct dirinfo uses time_t rather than raw FAT directory entry time fields. I plan to follow up on genericizing everything there (i.e. no FAT attributes). 5) unicode.c needed some redoing so that the file code does not try try to load codepages during a scan, which is actually a problem with the current code. The default codepage, if any is required, is now kept in RAM separarately (bufalloced) from codepages specified to iso_decode() (which must not be bufalloced because the conversion may be done by playback threads). Brings with it some additional reusable core code: 1) Revised file functions: Reusable code that does things such as safe path concatenation and parsing without buffer limitations or data duplication. Variants that copy or alter the input path may be based off these. To do: 1) Put dircache functionality back in the sim. Treating it internally as a different kind of file system seems the best approach at this time. 2) Restore use of dircache indexes in the playlist and database or something effectively the same. Since the cache doesn't have to be complete in order to be used, not getting a hit on the cache doesn't unambiguously say if the path exists or not. Change-Id: Ia30f3082a136253e3a0eae0784e3091d138915c8 Reviewed-on: http://gerrit.rockbox.org/566 Reviewed-by: Michael Sevakis <jethead71@rockbox.org> Tested: Michael Sevakis <jethead71@rockbox.org>
2013-12-16Introduce IHIFI760/960 targets.Andrew Ryabinin1-0/+3
Change-Id: Ie36e48742c0ed9aa3fd6f49aa034a11d2492327c
2013-11-05Introduce HiFi E.T. MA8/MA8C ports.Andrew Ryabinin1-1/+1
HiFi E.T. MA8 is almost the same as MA9 except another DAC(pcm1792 in ma8, df1704 in ma9). MA8 has ILI9342 lcd, MA8C has ILI9342C lcd. Change-Id: If2ac04f5a3382590b2a392c46286559f54b2ed6a
2013-11-05Introduce HiFi E.T. MA9C port.Andrew Ryabinin1-1/+1
The only difference between this target and HiFi E.T. MA9 is display driver (ILI9342 in MA9 and ILI9342c in MA9C) Change-Id: Icc3d2490f850902a653175360f12283f3708bbb7
2013-08-17Cleanup MV/MD macros a little.Michael Sevakis1-2/+2
When using variadic macros there's no need for IF_MD2/IF_MV2 to deal with function parameters. IF_MD/IF_MV are enough. Throw in IF_MD_DRV/ID_MV_VOL that return the parameter if MD/MV, or 0 if not. Change-Id: I7605e6039f3be19cb47110c84dcb3c5516f2c3eb
2013-05-06Introduce HiFi E.T MA9 port.Andrew Ryabinin1-0/+2
Change-Id: I79aadc958fd5222f26f91ed127f8c6fb2c465dc2
2013-02-01rk27xx: Increase timeout for sd card initialization. 1 sec isn't enough in ↵Andrew Ryabinin1-2/+4
some cases. Change-Id: I8d5384b53754e71b9a057a8602854d09b1885c68
2013-01-10rk27xx: substitute magic constants with meaningful names for INTCMarcin Bukat1-2/+2
Change-Id: Ic93114db351a9940a53d0c1df6439d82ada044e1
2013-01-10rk27xx: substitute magic constants with meaningful names for peripherials resetMarcin Bukat1-2/+2
Change-Id: Ia411c9be65376d1c3fdf59b7e692b0590d58775e
2013-01-10rk27xx: substitute magic constants with meaningful names for clock gatingMarcin Bukat1-3/+3
Change-Id: I6c66c7496db3db78e5c959414464826134dbe200
2012-12-16rk27xx: Add status led (icon) support to SD driverMarcin Bukat1-0/+2
Change-Id: I47a36c0cf7319c2b100b813fdcbea024c7ae0b0a
2012-04-20Fix typo.Andrew Ryabinin1-1/+1
Change-Id: Ib9bd947ac71370e11e7e3d67dbc5f16da0b15ae3
2012-04-20rk27xx: Remove debug use of timer1 in sd driver.Andrew Ryabinin1-1/+0
Change-Id: I720426de3c66c10273fff5f3a01ef6b692218a29
2012-02-28rk27xx: Make sure SD module clock is not gatedMarcin Bukat1-0/+1
Change-Id: Iafc9af6cf4762f16f367705b8c9a3e441420905b
2011-11-03Added HiFiMAN HM-801 target. FS#12355. This also renames tda1543.{ch} used ↵Andrew Ryabinin1-1/+7
by HM-60x to dummy_codec.{ch} as it works for PCM1704 used by HM-801. git-svn-id: svn://svn.rockbox.org/rockbox/trunk@30891 a1c6a512-1295-4272-9138-f99709370657
2011-09-06rk27xx - tweak a bit sd driver and add some debuging codeMarcin Bukat1-49/+92
git-svn-id: svn://svn.rockbox.org/rockbox/trunk@30447 a1c6a512-1295-4272-9138-f99709370657
2011-08-08Fix typos in comments. Thanks ukleinek for pointing out.Marcin Bukat1-3/+3
git-svn-id: svn://svn.rockbox.org/rockbox/trunk@30270 a1c6a512-1295-4272-9138-f99709370657
2011-08-08rk27xx sd driver fixesMarcin Bukat1-49/+76
git-svn-id: svn://svn.rockbox.org/rockbox/trunk@30269 a1c6a512-1295-4272-9138-f99709370657
2011-05-30Rockchip rk27xx port initial commit. This is still work in progress.Marcin Bukat1-0/+719
git-svn-id: svn://svn.rockbox.org/rockbox/trunk@29935 a1c6a512-1295-4272-9138-f99709370657